NuExplorer帮助简介

NuExplorer 2010.03帮助文档

北京玖瓯科技有限公司

网址：www.nunew.com

电话：010-62991069

NuExplorer 2010.03 版简介

NuExplorer 2010 是一款数学分析建模软件，广泛用于各个工程行业，对各行业的数据抽象为点、线、面、不规则面、切片和体数据，并提供一些行业的自定义的数据类型支持。 提供网格化插值, 卫星图工区投影,等值线追踪, 二维和三维可视化,面数据微积分和滤波等功能.同时它也是一个软件平台，能够运行在大部分主流的操作系统，如Windows, Mac, Linux/X11等，提供了数据文件和工程管理，显示窗口管理，插件管理，基础组件库，树状数据结构显示和多种窗口显示，多线程管理，信息提示管理，其所有工业上使用的功能来源于NuExplorer所提供的强大的插件支持功能。在NuExplorer的界面上任何地方单击鼠标右键将会有意外的惊喜。

是多国语言版本，支持中文版本和英文版本的切换。

NuExplorer 2010.03 版本提供的插件包括: 基础离散点数据模块，基础线数据模块 ，基础面数据模块，基础切片数据模块，基础体数据模块， 等值线追踪模块，面数据微积分和滤波模块，面数据变换模块，二维插值模块，三维插值模块，磁法电法模块，叠前地震模块，叠后地震模块，SPS处理模块。

插件简介：

=========================================

1. 基础点数据模块【NuScatteredBasePlugin(2010)】
1). 包括离散点数据加载和导出，离散点数据分布统计，在2D 和3D 窗口的显示和显示属性设置，菜单设置。
2). 离散点生成Delaunay三角网，三角网的属性统计，在2D和3D窗口的显示和显示属性设置，菜单设置。
3). 包括带属性离散点数据加载和导出，带属性离散点数据分布统计，在2D 和3D 窗口的显示和显示属性设置，菜单设置。

2. 基础线数据模块【NuLinesBasePlugin(2010)】
本模块提供折线数据、带属性的折线、折线组、带属性的折线组的加载和显示, 以及属性设置.

3. 基础面数据模块【NuSurfaceBasePlugin(2010)】
1). 包括7种面数据类型的加载和输出（包括常规的gis面数据文件和地学上的数据类型），面数据分布统计，面数据在2D 和3D 窗口的显示和显示属性设置，菜单设置。
2). 3D贴图面数据的创建和在2D和3D窗口显示（包括多种常规图形文件格式bmp,png,jpg,gif,tiff等），菜单设置。卫星图贴图在GIS中常用。
3). 输出面数据为散点数据。
4). 由面数据的有效网格点数据产生delaunay三角网，对其分布进行统计。

4. 基础切片数据模块【NuSliceBasePlugin(2010)】
切片数据模块提供空间平面平行四边形数据显示, 以及属性设置, 切片数据可以从体数据创建。.

5. 基础体数据模块【NuVolumeBasePlugin(2010)】
本模块提供自定义格式的体数据加载和显示, 以及属性设置。

=========================================

6. 等值线追踪模块【NuContourTracerPlugin(2010)】
本模块提供对面数据的等值线追踪和追踪参数设置，在2D和3D窗口中显示和显示属性设置，菜单设置。对一个面数据根据需要可产生多个等值线对象。此版本的等值线追踪功能不完善。

7. 面数据微积分和滤波模块【NuSurfaceStatisticPlugin(2010)】
1). 面数据统计功能提供根据面数据产生新的面数据，包括倾角，方位角，变差，二次偏导面数据和平均值曲面，高斯曲面，最大值曲面，最小值曲面，这些新产生的面数据网格与原始的面数据网格有相同的 x, y 网格坐标。
2). 快速数字滤波。提供一些具有默认设置功能的滤波方法，有中值滤波（m x n），平均值滤波（m x n），最大值滤波（m x n），最小值滤波（m x n）。
3). 详细数字滤波，提供60多种滤波方法。

8. 面数据变换模块【NuSurfaceTransformPlugin(2010)】
1) 面数据的几何变形和属性值修改和替换。.
2) 面数据和相同行列数的面数据的叠加运算。.

=========================================

9. 二维插值模块【NuEstimator2DPlugin(2010)】
二维插值模块提供了现在流行的大部分插值方法，包括克里金插值法, 反距离加权插值，修正谢别德方法插值，最近邻点插值，线性插值， 三角网法，算术平均法，局部多项式法，和十多种插值统计方法。可插值的数据为离散点数据和面数据，插值的结果为面数据。

10. 三维插值模块【NuEstimator3DPlugin(2010)】
三维插值模块提供通用的体插值方法, 克里金插值法, 反距离加权插值, 最近邻点插值, 算术平均, 和十多种插值统计方法. 可插值的数据为离散点数据, 面数据和体数据，插值的结果为离散点、线、面、切片、不规则面和体数据等NuExplorer 支持的基本数据类型。

=========================================

11. 磁法电法模块【NuMagneticsPlugin(2010)】
提供磁法延拓，磁法数据2D和3D显示，制作平剖图，切片图等。
提供电法扫面数据加载，2D和3D显示等。

=========================================

12. 叠前地震模块【NuPrevStackSeismicPlugin(2010)】
对叠前地震数据segy的加载解析和数据的2D和3D显示 ，属性设置和菜单设置。

13. SPS处理模块【NuSeismicSurveyPlugin(2010)】
处理地震勘测中SPS数据，布置观测系统，对观测系统进行2D和3D显示，属性设置和菜单设置。此模块常配合基础面数据模块中的卫星图贴图使用。

14. 叠后地震模块【NuPostStackSeismicPlugin(2010)】
对叠前地震数据segy的加载解析和数据的2D和3D显示 ，属性设置和菜单设置。


新建工程

打开NuExplorer, 有三种方打开“新建工程”对话框:

1. 工具栏上, 点击“新建工程”按钮.

2. "(F)文件"菜单, 点击"新建工程...".

3. 打开“开始页”, 点击"新建工程",

在“新建工程”对话框里,

点击“浏览...”按钮可以设定工程路径, 给定“工程名称”即新建一个工程.

新建工程被打开, 界面左边的"Data"框, "Task"框就被激活了.


打开工程

打开NuExplorer, 有三种方式可以打开一个已经存在的工程.

1. 工具栏上, 点击“(L)加载工程”按钮.

2. "(F)文件"菜单->“加载工程...”.

3. 打开“开始页”, 点击“工程”

然后弹出"Open Project"对话框如下:

选中一个工程文件(即.niou文件), "打开"后, 此工程即被加载进来.

此时菜单里的“(W)显示窗口”子菜单, 工具栏上的新建窗口按钮, 左边的"Data"框, "Task"框都被激活, 工作流程可以开始了.


打开最近工程

打开NuExplorer, 有两种方式可以打开一个已经存在的工程.

1. "(F)文件"菜单->"最近打开工程".

2. 打开“开始页”, "最近工程"栏里双击某个工程.

然后即可加载工程。如果工程已经在别的地方被删除，最近工程列表中还有，点击后会提示工程已删除，列表中相应的项也会被清除。.


卸载工程

NuExplorer有两种方式可以卸载一个已经打开的工程.

1. 工具栏上, 点击"(U)卸载工程"按钮.

2. “(F)文件”菜单->"(U)卸载工程...".

然后工程即被卸载.

此时菜单里的“(W)显示窗口”子菜单, 工具栏上的新建窗口按钮, 左边的"Data"框, "Task"框都是非激活状态, 工作流程了.


保存工程

NuExplorer有两种方式, 可以保存当前工程:

1. 工具栏上, 点击"保存工程"按钮.

2. “(F)文件”菜单, 点击"保存工程".


"Data"树操作

1. Data 树上分为三列，第一列为数据对象，第二列为数据对象的类型，第三列为数据对象的全局编号。

2. Data树上右键点击, 弹出菜单，菜单项根据插件决定，大部分菜单项由插件根据自己的功能添加。点击空白部分默认的菜单有“新建文件夹”

3. "Data"框里数据对象的操作. 树上的每个子对象都是可以拖动的. 如下图:

拖动数据对象. 拖动"scatterdata"到"New Folder22"下.

拖动数据对象. 把"scatterdata"从"1111Folder"拖动到根目录下.

拖动文件夹. 拖动"1111Folder"到"New Folder22"下, 那么"1111Folder"的所有子对象相应地也会被拖动.

.


新建文件夹

打开或新建一个工程后, 左边的"Data"框和"Task"框就被激活.

1. 在"Data"框里点右键, 选中菜单里的"新建文件夹",

即在"Data"框里新建一个文件夹.


文件夹操作

新建文件夹后, 一个文件夹出现在"Data"框里. 点击右键, 在右键菜单里, 有所有可以对文件夹进行的操作:

具体各个菜单项功能:

"New Folder"在当前文件夹下创建新文件夹..

"Delete"删除当前文件夹及其所有子对象.

"Properties"选中弹出属性对话框. 对文件夹属性进行设置.

.


层数据加载

面数据加载

打开或新建一个工程后, 左边的"Data"框和"Task"框就被激活.

需要基础面数据模块【NuSurfaceBasePlugin(2010)】。

支持的数据格式包括
GS ASCII - DSAA ,
GS Binary - DSBB ,
Surfer7 Binary - DSRB
CPS-3 Grid ASCII ,
Zmap Grid ASCII ,
Irap Classic ASCII ,
Irap Rms ASCII ,
EarthVison Grid ASCII

在"Data"框里点右键, 选中菜单里的"加载面文件", 弹出面数据格式选择对话框.

或者， 在"Task"框里, 双击"基础面模块"下的“加载面文件”, 弹出面数据格式选择对话框.

在面数据格式选择对话框里,

点击"浏览..."打开某个面数据文件, 可以预览文件信息.

另外, 左下选中左下角框里的数据格式, 可以预览选中格式的文件格式信息.

文件信息符合选中的文件格式, 点击"确定", 然后弹出选中格式的文件加载对话框. 如果文件和选中的格式不匹配, 点击"确定"后

会弹出错误提示对话框, 直到格式匹配为止.

具体的文件加载对话框里,

可以看到加载进来的文件几何数据信息, 这里可以更改对象名称"对象名称".

点击"确定"后, 数据就被加载进来, 同时出现在"Data"框里.


层数据加载

不规则面数据加载

打开或新建一个工程后, 左边的"Data"框和"Task"框就被激活.

需要基础面数据模块【NuSurfaceBasePlugin(2010)】。

支持的文本格式

在"Data"框里点右键, 选中菜单里的"加载面文件"，子菜单选择“加载不规则面”, 弹出加载对话框。

或者， 在"Task"框里, 双击"基础面模块"下的“加载面文件”, 弹出弹出加载对话框。

在面数据格式选择对话框里,

点击"浏览..."选择需要加载的文件

可以看到加载进来的文件几何数据信息, 这里可以更改对象名称"对象名称".

点击"确定"后, 数据就被加载进来, 同时出现在"Data"框里.


散点数据加载

离散点数据加载

打开或新建一个工程后, 左边的"Data"框和"Task"框就被激活.

需要基础点数据模块【NuScatteredBasePlugin(2010)】

一. 加载离散点

在"Data"框里点右键, 选中菜单里的"加载离散点", 弹出加载散点数据对话框.

或者在"Task"面板里, 双击"基础点模块"下的"加载离散点", 弹出加载散点数据对话框.

在加载散点数据对话框里,

点击"添加文件"： 加载离散点数据文件后, 文件路径信息会显示在左边的信息框里。可添加多个文件。

"对象名称"：可以更改将要生成的对象名称.

“每个文件产生一个文件夹”： 当需要加载的文件数大于1时将变得可编辑。标记是否每个文件生成一个离散点对象。

“产生文件夹”：标记是否为这些对多个文件产生的多个对象产生一个文件夹，文本框指定文件夹名称。

"几何位置和名称"：可以设定散点数据的几何结构，即那列是x,那列是 y，那列是z，并且指定x,y,z的名称。

"读取开始行"：文件将从设置的行开始读取，前边的跳过不读。.

"无效值"：设定无效数据值，产生的数据对象也将以此值为无效值.

"检查坐标重复"：检查重复数据行如何处理.选中情况下,数据x,y,z相同时只保留一个, 即不选中则不进行处理.

“分隔符”：一行数据中，用哪些符号来分隔两个数据，可多选。

"数据预览"：对数据进行预览.

点击"确定"后, 数据就被加载进来, 同时出现在"Data"框里.

二. 加载带属性离散点数据

在"Data"框里点右键, 选中菜单里的"加载离散点", 弹出加载散点数据对话框.

或者在"Task"面板里, 双击"基础点模块"下的"加载离散点", 弹出加载散点数据对话框.

在加载散点数据对话框里,

点击"添加文件"： 加载离散点数据文件后, 文件路径信息会显示在左边的信息框里。可添加多个文件。

"对象名称"：可以更改将要生成的对象名称.

“每个文件产生一个文件夹”： 当需要加载的文件数大于1时将变得可编辑。标记是否每个文件生成一个离散点对象。

“产生文件夹”：标记是否为这些对多个文件产生的多个对象产生一个文件夹，文本框指定文件夹名称。

"几何位置和名称"：可以设定散点数据的几何结构，即那列是x,那列是 y，那列是z，并且指定x,y,z的名称。

"读取开始行"：文件将从设置的行开始读取，前边的跳过不读。.

"无效值"：设定无效数据值，产生的数据对象也将以此值为无效值.

"检查坐标重复"：检查重复数据行如何处理.选中情况下,数据x,y,z相同时只保留一个, 即不选中则不进行处理.

“分隔符”：一行数据中，用哪些符号来分隔两个数据，可多选。

“添加” “清除” “清空”：设置属性列，可添加多个。每个点上可带多个属性，每行表示一个属性，可手工设置属性名和对应的在文件中的第几列。

“处理文件中列数小于设定的行”：当文件中的一行列数不够设定值时，可以舍弃此行或者用无效值代替属性。

"数据预览"：对数据进行预览.

点击"确定"后, 数据就被加载进来, 同时出现在"Data"框里.


折线数据加载

打开或新建一个工程后, 左边的"Data"框和"Task"框就被激活.

需要基础线数据模块【NuLinesBasePlugin(2010)】 。

支持文本格式的数据加载，文本格式可自设置。加载可设置为包括折线、折线组、带属性折线、带属性折线组。
折线是离散点顺序连接成的线；
折线组是多条折线的集合；
带属性的折线是折线上的每个点都有属性值的折线；
带属性的折线组指多条带属性的折线的集合。

数据格式样例：

以下数据可加载成为上述四类数据对象。各列的顺可颠倒，加载时靠设置各列的代表什么,数据分隔符可自定义。 折线组和带属性的折线组用行分割，分割行的格式也可自定义。

样例1：

x y z 属性1 属性2
312166 221404 2853.38 1302.5 0.76
312966 220892 2853.54 1394.2 3.19
313809 220354 2853.56 1357.5 0.98
314651 219814 2853.54 1365.3 -1.25
315747 219114 2853.54 1176.5 -0.1

316590 218575 2853.63 1302.5 2.1
317433 218036 2853.6 1213.2 2.2
287665 249397 2954.05 584.9 0.78
341799 184454 3230.4 471 3.11
288988 237420 2866.3 666 2.64

样例2：

x, y, 属性, z
312166, 221404, 1302.5 , 2853.38
312966, 220892, 1394.2 , 2853.54
313809, 220354, 1357.5 , 2853.56
314651, 219814, 1365.3, 2853.54
315747, 219114, 1176.5 , 2853.54

316590, 218575, 1302.5 , 2853.63
317433, 218036, 1213.2, 2853.6
287665, 249397, 584.9 , 2954.05
341799, 184454, 471, 3230.4
288988, 237420, 666 , 2866.3

一. 加载折线。

在"Data"框里点右键, 选中菜单里的"加载折线"，选择子菜单“加载折线”, 弹出加载折线数据对话框.

或者，在"Task"框里, 双击“基础线模块”下的“加载折线", 弹出加载折线数据对话框.

在加载折线数据对话框里,

点击"添加文件..."： 加载某折线数据文件后, 文件路径信息会显示在左边的信息框里.

"对象名称"：可以更改对象名称.

“每个文件产生一个文件夹”： 当需要加载的文件数大于1时将变得可编辑。标记是否每个文件生成一个离散点对象。

“产生文件夹”：标记是否为这些对多个文件产生的多个对象产生一个文件夹，文本框指定文件夹名称。

"空间位置名称"：可以设定折线数据的几何结构，设置x,y,z所在的列，设置x,y,z的名称。

"无效值"：设定无效数据值，产生的数据对象也将以此值为无效值.

“分隔符”：一行数据中，用哪些符号来分隔两个数据，可多选。

"数据预览"：对数据进行预览.

点击"确定"后, 数据就被加载进来, 同时出现在"Data"框里.

二. 加载带属性折线。

在"Data"框里点右键, 选中菜单里的"加载折线"，选择子菜单“加载带属性折线”, 弹出加载折线数据对话框.

或者，在"Task"框里, 双击“基础线模块”下的“加载折线组", 弹出加载折线组数据对话框.

在加载带属性的折线数据对话框里,

点击"添加文件"： 加载离散点数据文件后, 文件路径信息会显示在左边的信息框里。可添加多个文件。

"对象名称"：可以更改将要生成的对象名称.

“每个文件产生一个文件夹”： 当需要加载的文件数大于1时将变得可编辑。标记是否每个文件生成一个离散点对象。

“产生文件夹”：标记是否为这些对多个文件产生的多个对象产生一个文件夹，文本框指定文件夹名称。

"几何位置和名称"：可以设定散点数据的几何结构，即那列是x,那列是 y，那列是z，并且指定x,y,z的名称。

"读取开始行"：文件将从设置的行开始读取，前边的跳过不读。.

"无效值"：设定无效数据值，产生的数据对象也将以此值为无效值.

“分隔符”：一行数据中，用哪些符号来分隔两个数据，可多选。

“添加” “清除” “清空”：设置属性列，可添加多个。每个点上可带多个属性，每行表示一个属性，可手工设置属性名和对应的在文件中的第几列。

“处理文件中列数小于设定的行”：当文件中的一行列数不够设定值时，可以舍弃此行或者用无效值代替属性。

"数据预览"：对数据进行预览.

点击"确定"后, 数据就被加载进来, 同时出现在"Data"框里.

三. 加载折线组。

在"Data"框里点右键, 选中菜单里的"加载折线"，选择子菜单“加载折线组”, 弹出加载折线数据对话框.

或者，在"Task"框里, 双击“基础线模块”下的“加载折线组", 弹出加载折线数据对话框.

在加载折线组数据对话框里,

点击"添加文件..."： 加载某折线数据文件后, 文件路径信息会显示在左边的信息框里.

"对象名称"：可以更改对象名称.

“每个文件产生一个文件夹”： 当需要加载的文件数大于1时将变得可编辑。标记是否每个文件生成一个离散点对象。

“产生文件夹”：标记是否为这些对多个文件产生的多个对象产生一个文件夹，文本框指定文件夹名称。

"空间位置名称"：可以设定折线数据的几何结构，设置x,y,z所在的列，设置x,y,z的名称。

"无效值"：设定无效数据值，产生的数据对象也将以此值为无效值.

折线分割：折线以行来分割，可设置分割符号。

“列分隔符”：一行数据中，用哪些符号来分隔两个数据，可多选。

"数据预览"：对数据进行预览.

点击"确定"后, 数据就被加载进来, 同时出现在"Data"框里.

四. 加载带属性的折线组。

在"Data"框里点右键, 选中菜单里的"加载折线"，选择子菜单“加载带属性折线组”, 弹出加载折线数据对话框.

或者，在"Task"框里, 双击“基础线模块”下的“加载折线组", 弹出加载折线组数据对话框.

在加载带属性的折线组数据对话框里,

点击"添加文件"： 加载离散点数据文件后, 文件路径信息会显示在左边的信息框里。可添加多个文件。

"对象名称"：可以更改将要生成的对象名称.

“每个文件产生一个文件夹”： 当需要加载的文件数大于1时将变得可编辑。标记是否每个文件生成一个离散点对象。

“产生文件夹”：标记是否为这些对多个文件产生的多个对象产生一个文件夹，文本框指定文件夹名称。

"几何位置和名称"：可以设定散点数据的几何结构，即那列是x,那列是 y，那列是z，并且指定x,y,z的名称。

"读取开始行"：文件将从设置的行开始读取，前边的跳过不读。.

"无效值"：设定无效数据值，产生的数据对象也将以此值为无效值.

“分隔符”：一行数据中，用哪些符号来分隔两个数据，可多选。

折线分割：折线以行来分割，可设置分割符号。

“列分隔符”：一行数据中，用哪些符号来分隔两个数据，可多选。

“添加” “清除” “清空”：设置属性列，可添加多个。每个点上可带多个属性，每行表示一个属性，可手工设置属性名和对应的在文件中的第几列。

“处理文件中列数小于设定的行”：当文件中的一行列数不够设定值时，可以舍弃此行或者用无效值代替属性。

"数据预览"：对数据进行预览.

点击"确定"后, 数据就被加载进来, 同时出现在"Data"框里.


体数据加载

平行六面体网格数据加载

打开或新建一个工程后, 左边的"Data"框和"Task"框就被激活.

需要基础体数据模块【NuVolumeBasePlugin(2010)】 。

支持自定义格式的体数据加载。

加载体数据。

在"Task"框里, 双击“基础体模块”下的“加载文本格式体数据", 弹出"打开文件"数据对话框，选中文件加载。

点击"OK"后, 格式正确的数据文件就被加载进来, 同时出现在"Data"框里.


Delaunay三角网

Delaunay三角网格化

"Delaunay 三角网格化(XY)"即对数据进行三角网格化. 直接创建三角网数据, 显示在"Data"框.

按默认参数, 无需进行设置.

.


新建纹理面

新建贴图面

贴图面是再面上贴上图片，使用文理映射，支持常见的图片文件格式。可贴卫星图，薄片图等文件。

在面数据对象上单击右键，弹出右键菜单，单击"新建贴图面"在面数据的几何结构上创建新的纹理面数据对象。

对纹理面的操作, 见右键菜单属性设置.

.


散点数据显示

离散点数据加载进来后, 出现在"Data"框里.

1. 打开一个"3D"窗口, 将散点数据左侧的"checkbox"选中, 这时散点数据即显示在"3D"窗口里.

2. 打开一个"F"窗口, 将散点数据左侧的"checkbox"选中, 这时散点数据即显示在"F"窗口里.

一. 离散点

在"Data"框里点击散点数据的右键菜单, 选中"属性"项; 或者在窗口里选中数据对象, 弹出右键菜单, 选中"属性"项:

然后弹出散点数据属性对话框. "General"页主要是数据的几何属性及名称信息:

"Scatter"页主要是显示的方式以及位置参数设置.

"Colormap"页主要是色谱相关的显示参数设置.

二. 带属性的离散点

在"Data"框里点击带属性离散点数据的右键菜单, 选中"属性"项; 或者在窗口里选中数据对象, 弹出右键菜单, 选中"属性"项:


面数据显示

面数据加载进来后, 出现在"Data"框里.

1. 打开一个"3D"窗口, 将面数据左侧"checkbox"选中, 这时面数据即显示在"3D"窗口.

2. 打开一个"F"窗口, 将面数据左侧"checkbox"选中, 这时面数据即显示在"F"窗口.

在"Data"框里点击面数据的右键菜单, 选中"Properties"或者在窗口里选中数据对象, 弹出右键菜单, 选中"Properties"

然后弹出面数据属性对话框. "General"页主要是数据的几何属性及名称信息:

"Surface"页主要是显示的方式以及位置参数设置

"Colormap"页主要是色谱相关的显示参数设置

"Opacity"页设置面数据的透明度


折线数据显示

折线数据加载进来后, 出现在"Data"框里.

1. 打开一个"3D"窗口, 将折线数据左侧的"checkbox"选中, 这时折线数据即显示在"3D"窗口里.

2. 打开一个"F"窗口, 将折线数据左侧的"checkbox"选中, 这时折线数据即显示在"F"窗口里.

一. 折线

在"Data"框里点击折线数据的右键菜单, 选中"Properties"项; 或者在窗口里选中数据对象, 弹出右键菜单, 选中"Properties"项:

然后弹出折线数据属性对话框. "General"页主要是数据的几何属性及名称信息:

le

"折线"页主要是显示的方式以及位置参数设置.

"Colormap"

二. 折线组


新建纹理面

显示平行六面体

在平行六面体右键，创建各种切片，切片数据生成后, 出现在"Data"框里.

1. 打开一个"3D"窗口, 将纹理面左侧的"checkbox"选中, 这时面数据即显示在"3D"窗口里.

在"Data"框里点击切片的右键菜单, 选中"属性"项; 或者在窗口里选中数据对象, 弹出右键菜单, 选中"属性"项:

然后弹出切片属性对话框. "基本"页主要是数据的几何属性及名称信息:：

"Slice"页主要是设置当前切片序号：

下边是显示结果：

.


三角网格数据显示

散点数据加载进来后, 经"Delaunay Triangulation"后， 生成三角网格数据， 出现在"Data"框里，或者直接由面数据创建。.

1. 打开一个"3D"窗口, 将三角网数据左侧的"checkbox"选中, 这时三角网数据即显示在"3D"窗口里.

2. 打开一个"F"窗口, 将三角网数据左侧的"checkbox"选中, 这时三角网数据即显示在"F"窗口里.

在"Data"框里点击三角网数据的右键菜单, 选中"Properties"项; 或者在窗口里选中数据对象, 弹出右键菜单, 选中"Properties"项:

然后弹出三角网数据属性对话框. "General"页主要是数据的几何属性及名称信息:

"Delaunay"页主要是显示的方式以及位置参数设置.

"Colormap"页主要是色谱相关的显示参数设置.

以下是限制边长显示的效果:


新建纹理面

纹理面显示

在面数据上点击右键，单击新建贴图面，创建纹理面对象。

纹理面数据生成后, 出现在"Data"框里.

1. 打开一个"3D"窗口, 将纹理面左侧的"checkbox"选中, 这时面数据即显示在"3D"窗口里.

2. 打开一个"F"窗口, 将纹理面左侧的"checkbox"选中, 这时面数据即显示在"F"窗口里.

在"Data"框里点击纹理面的右键菜单, 选中"属性"项; 或者在窗口里选中数据对象, 弹出右键菜单, 选中"属性"项:

然后弹出纹理面属性对话框. "General"页主要是数据的几何属性及名称信息:

"Texture"页主要是设置贴图文件的路径, 预览, 以及设置映射的工区范围:

可设计多张图片，每张图片都有自己的左上脚和右下脚坐标。坐标不能重叠，大部分时候，图片坐标跟贴图面对象的坐标不一致。

允许贴图透明，可设置透明度。

下边是贴图前和贴图后的比较

.


面数据输出

"Data"框里, 选中面数据, 右键菜单点击"导出到文件":

"导出到文件"将面数据输出为其他格式面数据或者离散点数据.

支持文本格式包括:

GS ASCII(DSAA),

CPS-3 Grid,

Zmap Grid ASCII,

Irap Classic ASCII,

Irap Rms ASCII,

EarthVison Grid ASCII,

以及ASCII XYZ.

支持二进制格式包括:

GS Binary(DSBB),

Surfer 7 Binary(DSRB).

选定格式, 以"Surfer 7 Binary(DSRB)"为例, 如下图示, "Export"对话框里设定文件名称, 即输出数据.

.


面数据处理

面数据加载进来后, 出现在"Data"框里. 选中某个面数据后点击右键, 在右键菜单里, 有所有可以对面数据进行的操作:

不同的操作隶属于不同的插件模块, 如果某个插件没有安装, 那么相应的功能就不会出现在右键菜单上.

"追踪等值线": 属于等值线追踪模块(NuContourTracerPlugin(2010.03)).

"二维插值创建面对象": 属于二维插值模块(NuEstimator2DPlugin(2010.03)).

"查看数据表","转换成离散点","Delaunay三角网格化(XY平面)","新建贴图面","导出到文件": 属于基本面数据模块(NuSufaceBasePlugin(2010.03)).

"微积分", "数字化滤波": 属于面数据统计和滤波模块(NuSurfaceStatisticPlugin.dll(2010)).

"计算和替换": 属于面数据变换模块(NuSurfaceTransformPlugin.dll(2010.03)).

具体各个菜单项功能:

"追踪等值线": 对面数据进行等值线追踪, 生成等值线数据对象.

"二维插值创建面对象": 对面数据以不同方式进行插值. 创建网格化后的面数据.

"查看数据表": 以表格形式查看原始数据数值.

"Delaunay三角网格化(XY平面)": 对面数据进行delaunay三角网化. 创建新的三角网格数据.

"新建贴图面": 在面数据的几何属性基础上, 生成新的纹理面数据, 对其可以进行工区的纹理贴图.

"导出到文件": 把面数据输出为其他格式面数据或散点数据.

"微积分": 提供多种方式对面数据进行属性提取, 生成新的属性数据.

"数字化滤波": 提供多种方式对面数据进行滤波, 生成新的面数据.

"计算和替换": 提供面数据的加减乘除, 数值替换及平移等功能, 变换后生成新的面数据.

"属性": 选中弹出属性对话框. 对面数据显示属性进行设置.

"删除": 从当前工程中删除面数据对象.

.


散点数据处理

离散点数据处理

不同的操作隶属于不同的插件模块, 如果某个插件没有安装, 那么相应的功能就不会出现在右键菜单上.

一. 离散点

离散点数据加载进来后, 出现在"Data"框里. 选中某个散点数据后点击右键, 在右键菜单里, 有所有可以对离散点数据进行的操作:

"二维插值创建面对象"属于二维插值模块（NuEstimator2DPlugin(2010.03)）.

"Delaunay 三角网格化(XY平面方向)"属于基本层数据模块( NuScatteredBasePlugin(2010.03)）.

具体各个菜单项功能:

"二维插值创建面对象"对散点数据以不同方式进行插值. 创建网格化后的层数据.

"Delaunay 三角网格化(XY平面方向)"对散点数据进行delaunay三角网化. 创建新的三角网格数据.

"Properties"选中弹出属性对话框. 对散点数据显示属性进行设置.

二. 带属性的离散点

带属性的离散点数据加载进来后, 出现在"Data"框里. 选中某个带属性的离散点数据后点击右键, 在右键菜单里, 有所有可以对带属性的离散点数据进行的操作:

.


等值线追踪

"追踪等直线"菜单项即实现对层数据的等值线追踪功能.

在"Tracing Contour Parameters"对话框里.

"添加"：添加某个值进行等值线追踪.

"删除"：删除某个值, 即对这个值不再进行追踪.

“清空”：清空所有追踪级别的数据

"重置"：按默认间隔进行追踪.

"加载"：加载已有的等值线间隔设置.

"保存"：将当前等值线间隔设置进行保存.

.


网格化插值

二维插值(2D)

二维插值即知道很多二维样本（Xi,Yi, VALUEi）求需要估值点的(X,Y)的VALUE

二维插值包括： 克里金，反距离加权，修正谢别德方法，最邻近点，线性三角网，算术平均，数据度量（data metrics）,局部多项式。

在面数据对象上单击右键，弹出菜单上选择"二维插值创建面对象"菜单项里有多种插值方法对数据进行网格化插值.

.

或者在离散点数据对象上单击右键，弹出菜单上选择"二维插值创建面对象"菜单项里有多种插值方法对数据进行网格化插值.

不同的插值方法(以克里金为例), 参数设置包括以下三页:

"空间位置"页可以设置"线数", 即网格尺寸. "认为是同一个点当距离小于", 设置不同点的阈值，即当点距小于某个值时直接使用这个值，不再用其它采样点来估值。

"基本"页设置变差组件构建变差模型.

"搜索"页设置追踪区域以及半径等相关参数.

.


网格化插值

三维插值(3D)

三维插值即知道很多三维样本（Xi,Yi, Zi,VALUEi）求需要估值点的(X,Y,Z)的VALUE

三维插值包括： 克里金，反距离加权，修正谢别德方法，最邻近点，线性三角网，算术平均，数据度量（data metrics）,局部多项式。

"三维插值创建面对象"菜单项里有多种插值方法对数据进行网格化插值.

在带属性的离散点，带属性的折线，带属性的折线组，带属性的面，不规则面，切片，平行六面体上单击右键，在弹出菜单中选择三维插值成体，或者在Task 面板中 plug-in下的三维插值模块下选择一种插值方法，弹出插值对话框。

.

不同的插值方法(以克里金为例), 参数设置都包括以下三页:

"空间位置"页可以设置插值后的几何形状,。 "认为是同一个点当距离小于", 设置不同点的阈值，即当点距小于某个值时直接使用这个值，不再用其它采样点来估值。

"基本"页设置函数和模型.

"搜索"页设置追踪区域以及半径等相关参数.

.


微积分

在面数据对象上单击右键，在弹出菜单上单击"微积分"对面数据进行属性提取, 创建面数据基础上的属性面.

可以对面数据进行多种属性提取:

"Dip"即倾角

"Dip-Azimuth"即方位角

"Local Variability"即变差

"Second-Order Derivative"即二次偏导

'Mean Curvature"即平均值曲率

"Gaussian Curvature"即高斯曲率

"Maximum Curvature"即最大值曲率

"Mininum Curvature"即最小值曲率

.


数字滤波

在面数据对象上单击右键，在弹出菜单上单击"数字化滤波"对面数据进行滤波, 创建新的面数据.

可以对面数据进行数字滤波:

"Batch Digtial Filters"即对面数据进行批处理滤波, 创建多种面数据.

"Median Filtering"即中值滤波（m x n）

"Mean Filtering"即平均值滤波（m x n）

"Max Filtering"即最大值滤波（m x n）

"Min Filtering"即最小值滤波（m x n）.

.


面数据变换

面数据计算和替换

一. 计算

在面数据对象上单击右键，在弹出菜单上单击"计算和替换"下的子菜单“计算”对面数据进行变换, 创建新的面数据.

如上图, 可以对面数据进行加减乘除平移等变换, 生成新的面数据. 变换运算主要分两种:

1. 面数据常量运算.

"Z + 常数"：把面数据的z值加上一个常量，新创建的面x,y不变。

"Z - 常数"：把面数据的z值减去一个常量， 新创建的面x,y不变。

"Z × 常数"：把面数据的z值乘以一个常量，新创建的面 x,y不变。

"Z / 常数"：把面数据的z值除以一个常量， 新创建的面x,y不变。常数不能为零。

"x, y Offset, Z + 常数"：把面数据在x,y方向进行平移, z值加上一个常量.

"x, y Offset, Z - Surface"：把面数据在x,y方向进行平移, z值减去一个常量.

"x, y Offset, Z × 常数"：把面数据在x,y方向进行平移, z值乘以一个常量.

"x, y Offset, Z / Surface"：把面数据在x,y方向进行平移, z值除以一个常量，被除的面中网格点如果有0或者无效值的，则这个网格点结果为无效值。

如下图示:

Z方向偏移:

X,Y,Z方向偏移:

2. 面数据和相同几何尺寸(行列数都一致)面数据之间的运算.

"Z + 面"把面数据的z值和另一个"面"的z值相加.

"Z - 面"把面数据的z值和另一个"面"(行列数都一致)的z值相减.

"Z × 面"把面数据的z值和另一个"面"(行列数都一致)的z值相乘.

"Z / 面"把面数据的z值和另一个"面"(行列数都一致)的z值相除.

能够互相加减乘除的两个面必须是具有同样的网格数。

如下图示:

二. 替换

在面数据对象上单击右键，在弹出菜单上单击"计算和替换"下的子菜单“值替换”对面数据进行变换, 创建新的面数据.

单击菜单后会弹出对话框输入。

如果是清除或者替换大于，大于等于，小于，小于等于，则弹出如下对话框

如果是清除或者替换范围内的...,，则弹出如下对话框

.


显示"Start Page"页

NuExplorer有两种方式可以显示"Start Page"页:

1. 工具栏上, 点击"Start Page"图标.

2. "View"菜单下, 选中"Start Page"项.

[注] 软件打开时, 默认显示"Start Page"页.


新建"3D"窗口

有两种方式可以新建一个"3D"窗口。菜单和工具条要在新建工程或者打开工程后才可见。

在"Window"菜单下, 选中"New 3D Window"项.

或者 工具栏上, 点击"New 3D Window"图标.


新建"Face"窗口

有两种方式可以新建一个"Face"窗口:

1. "Window"菜单下, 选中"New Face Window"项.

2. 工具栏上, 点击"New Face Window"图标.


3D窗口操作

新建一个"3D"窗口, 并将一个数据对象显示在"3D"窗口后, 就可以从各个角度观察数据, 同时进行操作.

默认状态下:

鼠标滚轮可以对场景内物体进行缩放;

左键拖动可以对场景内物体进行旋转;

中键拖动可以对场景内物体进行平移;

右键上下拖动可以对场景内物体进行缩放;

左键右键按下可以选中场景内物体.

右键释放弹出选中物体的右键菜单.

3D窗口工具栏如下:

"Scene Setting"按下弹出场景设置对话框. 这里可以设置场景背景颜色, 开启或关闭灯光, 调节灯光强度, 可以设置轴, 以及场景边框的线宽, 颜色等.

"Print"按下弹出打印预览对话框. 这里可以尝试各种方式进行预览, 适应宽度, 适应高度, 适应窗口, 原始尺寸等. 然后点击打印, 即可将预览图片输出到打印机进行打印(如果安装了打印机).

"View All"可以全范围看到场景内物体.

"Target View"状态下, 点中物体某个位置, 可以自动调整相机, 近距离观察选中位置.

"Home"按下, 回到之前保存设定的相机状态.

"Set Home"将当前相机状态保存.

'Zoom In"放大场景内物体.

"Zoom Out"缩小场景内物体.

"Camera Ortho"设定当前相机为正交相机.

"Camera Perspective"设定当前相机为透视相机.

"Z Scale Up"将场景内物体在"Z"方向进行放大.

"Z Scale Down"将场景内物体在"Z"方向进行缩小.

"Z Scale Original"将场景内物体在"Z"方向回复原始比例.

"View From Left"从物体左侧观察物体.

"View From Right"从物体右侧观察物体.

"View From Top"从物体正上方观察物体.

"View From Bottom"从物体正下方观察物体.

"View From Frong"从物体前方观察物体.

"View From Back"从物体正后方观察物体.

"Move Left"将场景内物体向左平移.

"Move Up" 将场景内物体向上平移.

"Move Right" 将场景内物体向右平移.

"Move Down"将场景内物体向下平移.

"Show/Hide Axes"显示或者隐藏坐标轴.

"Show/Hide Boundary Box"显示或隐藏场景的边框线.


Face窗口操作

新建一个"Face"窗口, 并将一个数据对象显示在"Face"窗口后, 就可以从各个角度观察数据, 同时进行操作.

默认状态下:

鼠标滚轮可以对场景内物体进行缩放;

左键拖动可以对场景内物体进行旋转;

中键拖动可以对场景内物体进行平移;

右键上下拖动可以对场景内物体进行缩放;

左键右键按下可以选中场景内物体.

右键释放弹出选中物体的右键菜单.

Face窗口工具栏如下:

"Print"按下弹出打印预览对话框.

"View All"可以全范围看到场景内物体.

"Target View"状态下, 点中物体某个位置, 可以自动调整相机, 近距离观察选中位置.

"Home"按下, 回到之前保存设定的相机状态.

"Set Home"将当前相机状态保存.

'Zoom In"放大场景内物体.

"Zoom Out"缩小场景内物体.

"View From Left"从物体左侧观察物体.

"View From Right"从物体右侧观察物体.

"View From Top"从物体正上方观察物体.

"View From Bottom"从物体正下方观察物体.

"View From Frong"从物体前方观察物体.

"View From Back"从物体正后方观察物体.

"Move Left"将场景内物体向左平移.

"Move Up" 将场景内物体向上平移.

"Move Right" 将场景内物体向右平移.

"Move Down"将场景内物体向下平移.

"Show/Hide Axes"显示或者隐藏坐标轴.

"Show/Hide Boundary Box"显示或隐藏场景的边框线.


工作流程

NuExplorer常见工作流程有以下几种:

1.面数据显示

Surface Load->Display->Print.

面数据加载进来后, 直接在窗口显示打印制图.

2.面数据滤波

Surface Load->Digital Filter->Display->Print.

面数据加载进来后, 经过数字滤波进行平滑, 生成新的面数据对象. 然后在窗口显示, 打印制图.

3.面数据属性提取

Surface Load->Create Statistic Surface->Display->Print.

面数据加载进来后, 经过算法统计提取数据倾角等属性, 生成新的属性面数据对象. 然后在窗口显示, 打印制图.

Surface Load->Digital Filter->Create Statistic Surface->Display->Print.

面数据加载进来后, 经过数字滤波进行平滑, 生成新的面数据对象. 然后经过统计算法提取数据倾角等属性, 生成新的属性面数据对象. 最后在窗口显示, 打印制图.

4. 面重建

Load Scattered Data ->Creat Interploated Surface->Display->Print.

or, Load Scattered Data ->Delaunay Trianglulation(XY)->Display->Print.

散点数据加载进来, 经过三角或者四边形等网格化重建, 生成面数据对象. 然后在窗口显示打印制图.

Load Scattered Data ->Creat Interploated Surface->Digital Filter->Display->Print.

or, Load Scattered Data ->Delaunay Trianglulation(XY)->Digital Filter->Display->Print.

散点数据加载进来, 经过三角或者四边形等网格化重建, 生成面数据对象. 然后进行数字滤波平滑. 最后在窗口显示, 打印制图.

Load Scattered Data ->Creat Interploated Surface->Create Statistic Surface->Display->Print.

or, Load Scattered Data ->Delaunay Trianglulation(XY)->Create Statistic Surface->Display->Print.

散点数据加载进来, 经过三角或者四边形等网格化重建, 生成面数据对象. 经过算法统计提取数据倾角等属性, 生成新的属性面数据对象, 最后在窗口显示, 打印制图.

5. 等值线提取

Surface Load->New Contour->Display->Print.

面数据加载进来后, 右键新建等值线, 生成等值线数据对象. 然后在窗口显示打印制图.

Load Scattered Data ->Creat Interploated Surface->Display->Print.

or, Load Scattered Data ->Delaunay Trianglulation(XY)->Display->Print.

散点数据加载进来, 经过三角或者四边形等网格化重建, 生成面数据对象. 右键新建等值线, 生成等值线数据对象. 然后在窗口显示 打印制图.

6. 工区卫星图映射

Surface Load->New Texture Surface->Display->Print.

面数据加载进来后, 生成几何属性完全一致的纹理, 然后在纹理面对应的位置贴上卫星图, 即可显示真实的三维地形, 然后在窗口显示打印制图.

Load Scattered Data ->Creat Interploated Surface->New Texture Surface->Display->Print.

or, Load Scattered Data ->Delaunay Trianglulation(XY)->New Texture Surface->Display->Print.

散点数据加载进来, 经过三角或者四边形等网格化重建, 生成面数据对象, 在面数据基础上生成几何属性完全一致的纹理面 然后在纹理层对应的位置贴上卫星图, 即可显示真实的三维地形, 然后在窗口显示打印制图.

7. 面数据输出

面数据或者经过滤波面数据, 或者是提取的属性面, 除了可以在窗口显示外, 还可以进行各种格式转换, 最后输出存储.

8. 工程保存

所有的数据加载以及处理结果, 都可以经过工程保存储为工程文件, 然后再重新加载进来, 在原工程基础上进行新的处理, 避免了重复加载数据以及处理.


面数据变换

面数据计算和替换

在面数据对象上单击右键，在弹出菜单上单击"计算和替换"对面数据进行变换, 创建新的面数据.

如上图, 可以对面数据进行加减乘除平移等变换, 生成新的面数据. 变换运算主要分两种:

1. 面数据常量运算.

"Z + 常数"：把面数据的z值加上一个常量，新创建的面x,y不变。

"Z - 常数"：把面数据的z值减去一个常量， 新创建的面x,y不变。

"Z × 常数"：把面数据的z值乘以一个常量，新创建的面 x,y不变。

"Z / 常数"：把面数据的z值除以一个常量， 新创建的面x,y不变。常数不能为零。

"x, y Offset, Z + 常数"：把面数据在x,y方向进行平移, z值加上一个常量.

"x, y Offset, Z - Surface"：把面数据在x,y方向进行平移, z值减去一个常量.

"x, y Offset, Z × 常数"：把面数据在x,y方向进行平移, z值乘以一个常量.

"x, y Offset, Z / Surface"：把面数据在x,y方向进行平移, z值除以一个常量，被除的面中网格点如果有0或者无效值的，则这个网格点结果为无效值。

如下图示:

Z方向偏移:

X,Y,Z方向偏移:

2. 面数据和相同几何尺寸(行列数都一致)面数据之间的运算.

"Z + 面"把面数据的z值和另一个"面"的z值相加.

"Z - 面"把面数据的z值和另一个"面"(行列数都一致)的z值相减.

"Z × 面"把面数据的z值和另一个"面"(行列数都一致)的z值相乘.

"Z / 面"把面数据的z值和另一个"面"(行列数都一致)的z值相除.

能够互相加减乘除的两个面必须是具有同样的网格数。

如下图示:

.